Dell and McAfee Require Internet Explorer 5.x or higher

Martin Belam  by Martin Belam, 30 April 2005

So, it wasn't enough to bundle and automatically get going McAfee's Anti Virus software on my new PC, or email reminders about the expiry of my free subscription to me, Dell and McAfee also want to dictate to me that I must use the most insecure of the major browsers.

McAfee Browser Specification Requirements

Keep up to date on my new blog